How Should I Handle Items?

Whether you're a newbie or an experienced programmer, any questions, help, or just talk of any language will be welcomed here.

Moderator: Coders of Rage

Post Reply
User avatar
davidthefat
Chaos Rift Maniac
Chaos Rift Maniac
Posts: 529
Joined: Mon Nov 10, 2008 3:51 pm
Current Project: Fully Autonomous Robot
Favorite Gaming Platforms: PS3
Programming Language of Choice: C++
Location: California
Contact:

How Should I Handle Items?

Post by davidthefat »

Should I make a class like this?

Code: Select all

class Items
{
int Cost;
char ItemName[15];
int SpriteID;
int ThumbID;
char iType[10];
void SetItem(int TempCost, char TempName[15], intTempSprite, int TempThumb, char TempType);
};
User avatar
MarauderIIC
Respected Programmer
Respected Programmer
Posts: 3406
Joined: Sat Jul 10, 2004 3:05 pm
Location: Maryland, USA

Re: How Should I Handle Items?

Post by MarauderIIC »

Something like that. Although your class name should probably be singular and your member names should probably start with a lowercase letter and be indented.
I realized the moment I fell into the fissure that the book would not be destroyed as I had planned.
User avatar
thejahooli
Chaos Rift Junior
Chaos Rift Junior
Posts: 265
Joined: Fri Feb 20, 2009 7:45 pm
Location: London, England

Re: How Should I Handle Items?

Post by thejahooli »

MarauderIIC wrote:Something like that. Although your class name should probably be singular and your member names should probably start with a lowercase letter and be indented.
Your code is fine I would would just change your naming of variables and classes to make them like this

Code: Select all

class Item // take away 's' to not make it plural
    {
    int cost; // for all variables I have the first letter of the first word lowercase
    char itemName[15];
    int spriteID;
    int thumbID;
    char itemType[10]; // I changed it from iType to itemType as this is easier to read and use
    void SetItem(int tempCost, char tempName[15], int tempSprite, int tempThumb, char tempType);
    };
sorry for telling you how you should write your code but this is the normal, or at least widely used, so others can easily read and use your code.
I'll make your software hardware.
Post Reply