LeonBlade wrote:D-e-X wrote:Looks nice and clean, however, you should comment or rename such variables as "int i = 0;"

I don't think i really needs much explanation but.
First of all, "but" what?
Second of all, it's his first project, and I'm just pointing out that even though "i" might be obvious here, having i, j, k, or x everywhere (in a bigger project) without a name related to its usage, (like by convention it should have) makes it unnecessarily hard to grasp the point of its existence.
Of course, people would understand those used in for loops or as counters by general, you don't have to write:
Code: Select all
int counter = 0;
int someVar = 3;
for(;counter < someVar; ++counter) {
std::cout << "HAI!" << "\n";
}
But when the counter itself is used for something specific (not just in loops, but also in if statements and others), it's good design to name it something that explains its use. I know this got redundant, but I'm just trying to get my point across. HOWEVER, note that this is partly subjective and I am no one to tell EXACTLY how it should be

, so excuse any ignorance that might be.
I remember when I used to be into nostalgia.